Safari shows blue dot below Dock icon though it's not in process table

2018-02-17 07:04:22

Summary:

Safari is running according to the Dock (icon has dot below it, and right-click shows "Force Quit"); however Activity Monitor doesn't show it and ps -ef | grep -i saf returns nothing. Relaunching the Dock does nothing. Safari won't open a window, nor will it quit.

Is there anything I can do to repair this short of restarting?

Full details:

I ran into a problem with Safari. It froze. So I tried Force Quit.

It seemed to work (blue dot below Dock icon disappeared). I clicked the icon to restart Safari. It bounced. A couple minutes later, I noticed it still bouncing. I right clicked and Force Quit again.

I clicked Safari and nothing happened. The blue dot did not appear below the icon. I right clicked and saw a "Force Quit" option — even though Safari was not running, and there was no blue dot.

I relaunched the Dock. (Using TinkerTool's button for that purpose.) The blue dot reappeared under the Safari icon, but clicking the icon didn't accomplis