Google Now launches when headphones are plugged in

2017-12-12 12:00:14

I recently got a new LG G2 from T-Mobile and it worked perfectly fine but now When ever I plug in my headphones it randomly opens Google Now. It always says "speak to search" or it turns the music or what ever I am listening to maximum volume. And when my device is locked with my password it just repeats "Please unlock the device". Can someone help me?

Are you using the headphones that came with the phone? If not that could be why.

Even if they're genuine Apple EarPods or Beats - it looks as though the main issue is the middle button in the headphone is stuck while pressed in.

SO this has to do with the 3.5mm audio port on thje device.

With special headphones (the ones with controls on the wire) this feature gives you the ability to voice search without taking out the device. but for you (and me) it just bugs out.

basically the male headphone port is brushing up against the designated special area on the female port (top kek) and giving it the signal to do

  • Are you using the headphones that came with the phone? If not that could be why.

    Even if they're genuine Apple EarPods or Beats - it looks as though the main issue is the middle button in the headphone is stuck while pressed in.

    2017-12-12 12:37:26
  • SO this has to do with the 3.5mm audio port on thje device.

    With special headphones (the ones with controls on the wire) this feature gives you the ability to voice search without taking out the device. but for you (and me) it just bugs out.

    basically the male headphone port is brushing up against the designated special area on the female port (top kek) and giving it the signal to do whatever (google now, modify volume, ect)

    You cant fix it as of now, but if the device is in sleep mode or whatever google now wont open, and powerAmp has an option to disable volume modification.

    and thats about it.

    2017-12-12 12:38:06
  • I used Titanium Backup to freeze the Google app responsible for Google voice search (I don't use it). Now everything is back to normal again, like I expect it too.

    2017-12-12 13:00:31
  • Go to Settings->Installed Apps. Find Google Now app or Google app (whichever one is annoying you). Either disable the app or deny the microphone permission. Thats it.

    2017-12-12 13:30:42