Remove emacsclient startup message

2018-10-23 10:00:11

How do I go about removing the message "When done with this frame, type C-x 5 0" when launching emacsclient?

I know it's possible to controll the startup message of emacs when not launched as a daemon by changing the display-startup-echo-area-message function, but it has no effect when I launch emacs with "emacsclient -c"

The way you launch emacsclient now, the call blocks the terminal session and releases it only after you kill the frame. Hence the message. If you add the -n or --no-wait option, the terminal is released immediately and you will not see the message.

Additionally, you might want to use option -nw to avoid Emacs creating a new frame.

Create a short shell alias that includes all options that you use. I use em.

  • The way you launch emacsclient now, the call blocks the terminal session and releases it only after you kill the frame. Hence the message. If you add the -n or --no-wait option, the terminal is released immediately and you will not see the message.

    Additionally, you might want to use option -nw to avoid Emacs creating a new frame.

    Create a short shell alias that includes all options that you use. I use em.

    2018-10-23 12:37:34